Jump to content
mundek

Horus X10S wgrywanie zdjęć , play track - problem

Recommended Posts

Witam , posiadam nadajnik Horus X10S z oprogramowaniem FrOs i dwa problemy . Pierwszy to wgrywanie zdjęć modeli , udało mi się zapisać 11 zdjęć modeli i dalej ni w ząb nie mogę więcej . 

Fotki pomniejszone do rozdzielczości 155 na 100 . Nadajnik włączony podłączam do laptopa , wchodzę na dysk USB nadajnika , IMAGES  _ MODELIMAGES , zapisuję pomniejszone zdęcie i zamykam program . Plik jest zapisany w SYSTEM _ FILES _ FLASH _IMAGES _ MODELIMAGES i widoczny jest  np. SUKHOY.JPG w nadajniku . Gdy chcę dodać fotkę do zaprogramowanego modelu - MODEL SEL _ MODIFY _ IMAGE , fotka nie jest widoczna . Poprzednie fotki zapisywałem w ten sam sposób z rezultatem pozytywnym . Nie wiem w czym problem , miejsce na dysku jeszcze jest .

Podobnie jest z polskimi  komunikatami  głosowymi , kilka zapisanych w FILES _ FLASH _ SOUNDS _ EN _ TRACK i zaprogramowane w funkcjach specjalnych nadajnika , odtwarzają się prawidłowo . Po jakimś czasie zapisałem ich jeszcze kilka , tak samo jak poprzednio . Niestety nie  są widoczne w funkcjach specjalnych nadajnika , gdy próbuję je przypisać do jakiegoś przełącznika . Soft w nadajniku 1.3.06 , najnowszy , po za tym wszystko ok . Robię coś nie tak ?

 

Share this post


Link to post
Share on other sites

Czasem problemem jest format pliku JPG i WAV. Miałem już przypadki, że pliki JPG generowane jakimś przypadkowym programem (niestety nie pamiętam jakim) się nie otwierały. Ten sam plik zapisany przez Photoshop działał. Podobnie i jeszcze częstsze jest to w przypadku plików audio. Warto podejrzeć jakie są parametry plików działających i tak samo zapisywać pliki generowane.

Share this post


Link to post
Share on other sites

Dziękuję za odpowiedź , za zasugerowanie w którą stronę pójść . Poradziłem sobie w ten sposób że robię podmiankę fotki która się wyświetla , w jej miejsce wklejam nową i działa . W podobny sposób spróbuję z plikami dźwiękowymi WAW . Pozdrawiam .

Share this post


Link to post
Share on other sites
Dnia 20.01.2020 o 21:47, mundek napisał:

Dziękuję za odpowiedź , za zasugerowanie w którą stronę pójść . Poradziłem sobie w ten sposób że robię podmiankę fotki która się wyświetla , w jej miejsce wklejam nową i działa . W podobny sposób spróbuję z plikami dźwiękowymi WAW . Pozdrawiam .

Wydaje mi się, że to nie powinno tak działać – w sensie, że trzeba podmieniać pliki. Czy wersja FrOS jest najnowsza?

Share this post


Link to post
Share on other sites

Tak , najnowsza V 1.3.06 . Fotki tak wchodzą , plików WAW nie próbowałem .

Na razie walczę z innym problemem , zaktualizowałem nadajnik i odbiornik RX8R do najnowszej  wersji FCC i nie chce mi się zbindować .

Po przeczytaniu artykułu o problemach w trybie D16 EU , wyjaśniło się dlaczego miałem w ubiegłym sezonie trzy przypadki niesterowności modelu .

Pierwszy z szybowcem bez ustawionego trybu Failsfe , model w krążeniu spadł na ziemię , cały na szczęście .

Drugi , szybowiec już z ustawionym trybem Failsafe , z wysokości około 50m  , bez kontroli odleciał ślizgiem , miałem daleki spacer , model cały .

Trzeci z helikiem Trex 450 , tu nie było już tak wesoło .

Nie twierdzę ze 100 procentową pewnością że to z powodu nagłośnionego problemu , ale może jest to jakieś wytłumaczenie opisanych przypadków . Modeli mam kilka z odbiornikami pracującymi w trybie D16  , w pozostałych problemu z zasięgiem nie zauważyłem . Jest nadzieja że po aktualizacjach problemu nie będzie .

Share this post


Link to post
Share on other sites

W kwestii "obrazków" w tym dokumencie:
https://www.frsky-rc.com/wp-content/uploads/Downloads/HOW TO/FrSky Horus X12 Production System Firmware Flashing Companion 10-29-17.pdf

napisano dla FrOS w X12S:
"Size 50K or less, max number <100, name length up to 30 chars (.jpg extensions not included), format jpg 155x100 (larger or smaller size will not display as well, cut off, etc.."

 

Z kolei dla dźwięków w https://opentx.gitbooks.io/manual-for-opentx-2-2/content/advanced/audio.html napisano:

"Audio File Format

  • File Name: 123456.wav (up to 6 characters plus .wav)
  • Sample Rate: 32 kHz (or 16 Khz, 8Khz)
  • Bits / Sample: 16 (or 8 )
  • Tracks: 1, mono
  • Compression Codec: PCM (or u-law, a-law)"

Co do problemów z bindowaniem po upgrade, upewnij się, że masz kompatybilne wersje firmware w nadajniku i odbiorniku. Opisy plików firmware są niejednoznaczne. Wersja "światowa" może być opisana jako FCC albo jako NEU (No EU), a europejska jako EU, LBT, EU-LBT, można się łatwo pomylić.
Dodatkowo Twój RX8R ma dostępne firmware dla ACCST jak i ACCESS, jeśli z rozpędu wybrałeś to drugie, to nie zbindujesz się z X10S (zakładam, że nie montowałeś "kitu" rozszerzającego). Dalej, jeśli pomieszasz ACCST z ACCST v2, też nie zbindujesz.
PS. Dlaczego wybrałeś FCC a nie wersję europejską?

Edited by komarkus

Share this post


Link to post
Share on other sites

Dzięki za podpowiedzi w sprawie (obrazków) i plików dźwiękowych , będę rozpracowywał .O FCC myślałem w związku z opisanymi wyżej przypadkami . Na razie po nieudanych próbach aktualizacji nadajnika i odbiornika ( pewnie gdzieś popełniłem błąd ) powróciłem do poprzedniej wersji nadajnika 1.3.06 EU V1. Odbiornik zbindowany z nadajnikiem , już myślałem że coś uszkodziłem . Jutro na spokojnie powrócę do aktualizacji w wersji 1.3.06 EU V2 .

Share this post


Link to post
Share on other sites
15 godzin temu, mundek napisał:

Po przeczytaniu artykułu o problemach w trybie D16 EU , wyjaśniło się dlaczego miałem w ubiegłym sezonie trzy przypadki niesterowności modelu .

Pierwszy z szybowcem bez ustawionego trybu Failsfe , model w krążeniu spadł na ziemię , cały na szczęście .

Drugi , szybowiec już z ustawionym trybem Failsafe , z wysokości około 50m  , bez kontroli odleciał ślizgiem , miałem daleki spacer , model cały .

Trzeci z helikiem Trex 450 , tu nie było już tak wesoło .

Patrząc na opisy przypadków z szybowcem, to przyczyną raczej nie był niedawno odkryty błąd D16 EU-LBT. Ten błąd, jeśli już wystąpi (a występuje rzadko, w bardzo "zaszumionych" warunkach radiowych), to jest to pojedyncze i bardzo krótkotrwałe (poniżej 1 sekundy) zamrożenie serw, ewentualnie połączone z niekontrolowanym wychyleniem jednego serwa (ale niekoniecznie).  Po momencie wszystko wraca do normy. Z tego co piszesz, to modele utraciły kontrolę na o wiele dłużej. Oczywiście trzeba by się temu przyjrzeć i byłoby świetnie poznać przyczynę, ale to nie przypadek ostatnio wykrytego błędu D16 EU-LBT.

Trochę abstrahując, ale co do ustawienia failsafe - warto ustawić np. lekkie wychylenie steru kierunku, inne powierzchnie sterowe w neutrum, silnik wyłączyć albo na idle – dzięki model nie odleci daleko. Jeśli jest na pokładzie, to warto uruchomić auto-poziomowanie, zwiększa to szansę na niekontrolowane, ale łagodne lądowanie. W heli ustawiam wyłączenie silnika, auto-poziomowanie (aktywację rescue FBL), skok wirnika głównego na +1deg, reszta w neutrum. Test ustawień można zrobić pod przełącznikiem, ustawiając takie same wartości kanałów jak dla failsafe. W ten sposób można bezpiecznie sprawdzić, jak teoretyczne ustawienia działają w praktyce i ew. skorygować. W heli wystarczy poprawnie ustawić kąt i czas rescue, a potem ten minimalny +1deg skoku witnika i neutrum dla reszty kanałów.

Share this post


Link to post
Share on other sites

Wracając jeszcze do obrazków i dźwięków, dla X10S z FrOS, jest manual u FrSky:

https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/X10-X10S/Manual-X10 X10S.pdf

"Model images: The size should be equal or smaller then 50K, 100 is the maximum allowed images in the folder, located in the folder “IMAGE/MODELIMAGES/”. The recommended size is 155x100 (colour: 16bit, RGB 565, 72DPI), smaller images will be displayed in the top left corner, larger images will be cut to fit the available space. Up to 50 characters are available to name the created image file, but 20 is recommended as a maximum in order for it to fit on the menu screens.
Track files: located in the folder “SOUNDS/en/TRACK/”. The size should be equal or smaller then 100K, 100 is the maximum allowed images in the folder name length should be less than 10 characters and must have the .wav format."


I jeszcze sprostowanie. Wyżej napisałem, że dla RX8R (Pro) jest dostępny ACCESS, na razie nie ma, choć dla RX6R i RX4R jest.

Share this post


Link to post
Share on other sites

Tak , dlatego napisałem że prawdopodobna przyczyna opisanych przypadków z szybowcem i helikiem . Jak się do końca nie jest w stanie zdiagnozować przyczyny , to wziąłem i ten przypadek z D16 EU pod uwagę . Podejrzewałem awarię , przegrzanie układu BEC w ESC , po kraksach jak podszedłem bliżej , wszystko w modelach działało . ESC powymieniałem i więcej problemów nie zauważyłem . Ster kierunku w szybowcu , po tym długim spacerze , już wychyliłem .

Odnośnie helika , zawsze się zastanawiałem jakie ustawienia wybrać dla trybu failsafe . Jak latało się z flaibarem  to ciężko było wybrać jakieś sensowne ustawienia . Od niedawna latam na systemie FBL MSH Brain , i tutaj już można ustawić zasugierowane wyżej ustawienia . Ale zamiast rescue ( model w tym trybie nabiera jeszcze wysokości ) lepiej autolevel , tylko taka moja sugestia .

Share this post


Link to post
Share on other sites
19 godzin temu, mundek napisał:

Odnośnie helika , zawsze się zastanawiałem jakie ustawienia wybrać dla trybu failsafe . Jak latało się z flaibarem  to ciężko było wybrać jakieś sensowne ustawienia . Od niedawna latam na systemie FBL MSH Brain , i tutaj już można ustawić zasugierowane wyżej ustawienia . Ale zamiast rescue ( model w tym trybie nabiera jeszcze wysokości ) lepiej autolevel , tylko taka moja sugestia .

Rescue działa też w inverted, najpierw nabierając wysokości. Można regulować czas, przez jaki jest aplikowany pozytywny (lub negatywny) pitch, wiec za wiele wysokości nie nabierze, a może to zatrzymać utratę wysokości, jeśli model opadał. Więc jakiś kompromis. Przydało by się mieć rescue normalne, pod przełącznikiem i oddzielne rescue dla failsafe (np. zawsze odwracający heli i z krótszym albo zerowym czasem wznoszenia). Nie wiem, czy aktywacja auto-poziomowania odwróci model będący w inverted...

19 godzin temu, komarkus napisał:

I jeszcze sprostowanie. Wyżej napisałem, że dla RX8R (Pro) jest dostępny ACCESS, na razie nie ma, choć dla RX6R i RX4R jest.

Wszyscy czekają na RX8R Pro :).

Do niedawna był jeszcze XM+, ale już nie ma. Zapewne zabrakło miejsca w pamięci jego flash na firmware ACCESS 1.1.3+.

Share this post


Link to post
Share on other sites

Witam , rescue mam pod przełącznikiem chwilowym , faktycznie może  lepiej ustawić rescue dla failsafe . Silnik i tak odetnie a energia z łopat i tak za wiele go nie podniesie .

Experymentować raczej nie będę . 

Odnośnie ACCESS , czekam na artykuł na ten temat , jeszcze niedostępny , w redagowaniu . Nie wiem co ten  system wnosi nowego , nie wiem czy to widziałem na stronie Frsky ,

zestaw modułów do aktualizacji ACCESS nadajnika X10S , pozwoli na samodzielną modernizację nadajnika ?

O co kaman z tym RX8R Pro ?

 

 

 

 

 

Share this post


Link to post
Share on other sites
8 godzin temu, mundek napisał:

Witam , rescue mam pod przełącznikiem chwilowym , faktycznie może  lepiej ustawić rescue dla failsafe . Silnik i tak odetnie a energia z łopat i tak za wiele go nie podniesie .

Tym niemniej wytraci nieco (albo sporo) energii wirnika, więc potem model może spadać jak kamień. Do tej pory używam standardowego 0.6 sek dla trwania wznoszenia w rescue, ale mam wrażenie, że można to spokojnie zmniejszyć do 0.4, może nawet 0.3 sek.

8 godzin temu, mundek napisał:

Odnośnie ACCESS , czekam na artykuł na ten temat , jeszcze niedostępny , w redagowaniu . Nie wiem co ten  system wnosi nowego , nie wiem czy to widziałem na stronie Frsky ,

zestaw modułów do aktualizacji ACCESS nadajnika X10S , pozwoli na samodzielną modernizację nadajnika ?

Artykuł mam prawie gotowy, ale ciągle coś nowego się pojawia. Myślę, że opublikuję go w ciągu najbliższych dwóch tygodni. Najwyżej będę uzupełniał.

Tak, zestaw pozwala na samodzielną modernizację. Tyle tylko, że o ile wymiana modułu nadawczego jest prosta, to wymiana modułu bluetooth już nie do końca. Tzn. jest, jeśli ma się wprawę w lutowaniu, a raczej rozlutowywaniu.

8 godzin temu, mundek napisał:

O co kaman z tym RX8R Pro ?

RX8R Pro jest fajnym odbiornikiem, zastępującym zasłużony X8R. Tyle, że nie ma do niego (jeszcze?) firmware ACCESS.

Dnia 23.01.2020 o 22:00, komarkus napisał:

"Model images: The size should be equal or smaller then 50K, 100 is the maximum allowed images in the folder, located in the folder “IMAGE/MODELIMAGES/”. The recommended size is 155x100 (colour: 16bit, RGB 565, 72DPI), smaller images will be displayed in the top left corner, larger images will be cut to fit the available space. Up to 50 characters are available to name the created image file, but 20 is recommended as a maximum in order for it to fit on the menu screens.
Track files: located in the folder “SOUNDS/en/TRACK/”. The size should be equal or smaller then 100K, 100 is the maximum allowed images in the folder name length should be less than 10 characters and must have the .wav format."

Przeoczyłem to. Jak teraz czytam, to prawdopodobnie w moim przypadku nie chodziło o program zapisujący JPEG jako taki, ale o to, że miałem różne ustawienia kompresji i programy zapisywały pliki różnych rozmiarów. Być może Photoshop mniejsze niż 50kB i było ok, a ten drugi generował większe pliki i nie działało.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...