Jump to content

Bindowanie a wersje EU-LBT


Recommended Posts

Kupiłem przed świętami u Was X9D Plus i z tydzień później odbiornik X8R i mam problem z bindowaniem. Na opakowaniu nadajnika mam naklejkę EU-LBT więc zakładam, że ma firmware nowy europejski. Z Taranisie tam gdzie opcja wyboru wewnętrznego modułu nadawczego mam do wyboru None, D16 i LR12 więc posiłkując się tym artykułem: http://www.dronetrest.com/t/frsky-eu-lbt-firmware/1666 stwierdziłem, że mam również wersję EU-LBT (bo jakby było jeszcze do wyboru D8 to bym miał wersję International, a jakby było tylko None i D16 to bym miał pewnie wcześniejszą starą wersję firmware EU).

Mimo tego, że mam wersję EU-LBT (przynajmniej wg naklejki na opakowaniu) w X8R i EU-LBT w X9D Plus to nie mogę zbindować odbiornika - mam na stałe świecący czerwony i zielony po wciśnięciu F/S na odbiorniku, co znów wg tego filmu: 

oznacza, że mam oznakę typową dla niezgodności firmware jeśli chodzi o wersje International / EU-LBT. Teraz pytanie: czy mam się już zabierać za jakiś update firmware, czy coś pominąłem przy bindowaniu, że mi X8R tak świeci bez reakcji? 

Link to post
Share on other sites

"Duch" Twojej wypowiedzi mówi mi, że robisz błąd. Odbiornik do bindowania włączamy do zasilania z wciśniętym F/S, efekt będzie po wyłączeniu i ponownym włączeniu zasilania odbiornika. A Ty, zdaje się, naciskasz F/S po włączeniu zasilania odbiornika. Wszystko zrób dokładnie tak jak opisano w tym artykule:
https://77hobby.pl/bindowanie-odbiornikow-frsky-serii-lr-x-d-oraz-v-n-8.html

Link to post
Share on other sites
  • Moderators

Zapoznaj się z tym artykułem:

http://77hobby.pl/firmware-nadajnikow-i-odbiornikow-frsky-kompendium-n-21.html

Bindowanie przeprowadź dokładnie wg linku podanego przez komarkusa, krok po kroku.

Jeśli sprzęt był kupowany u nas, kilkanaście dni temu, to na pewno ma firmware EU-LBT. Nie sprzedajemy innego. Dodatkowo zawsze sprawdzamy i bindujemy wysyłane odbiorniki. Przed wysyłką sprawdzamy też radia (bindując z warsztatowym odbiornikiem lub z wysyłanym, jeśli były kupowane razem). Zatem (prawie) na pewno wszystko jest w porządku ze sprzętem i firmware.

OpenTX jest w wersji 2.1.9, bo taką (z wyboru) wgrywamy do X9D. To ostatnia stabilna wersja serii 2.1. Seria OpenTX 2.2 została przygotowana dla Horusów, niewiele się różni od 2.1. Ma ją sens wygywać do Horusów właśnie albo w przypadku kiedy potrzeba tych kilku nowych funkcji, których nie ma w 2.1 (mało prawdopodobne na początku przygody z OpenTX).

OpenTX lepiej nazywać oprogramowaniem systemowym radia (nie firmware), właśnie dlatego, aby uniknąć pomyłki z firmware modułu nadawczego i odbiornika (EU-LBT / międzynarodowe).

OpenTX jest w wersji EU, dlatego nie masz aktywowanego trybu D8. Jest to opisane w artykule, do którego link podałem powyżej. Nie ma to wpływu na bindowanie w trybie D16 i na razie polecałbym nie wymieniać wersji OpenTX, a skupić się na rozwiązaniu problemu z bindowaniem.

Zerknij też tutaj:

EDIT: D16-EU ze zdjęcia się nie przejmuj. Był krótki czas, kiedy takie oznaczenie było stosowane w OpenTX EU od FrSky. Ale nawet wtedy nie miało ono żadnego wpływu na firmware modułu nadawczego. Teraz jest po prostu D16. Zawsze to firmware modułu nadawczego determinuje, czy jest używana wersja EU-LBT czy międzynarodowa.

Link to post
Share on other sites

Dzięki za odpowiedź. Taranis został kupiony osobno (wcześniej) niż X8R więc nie był ze sobą bindowane. 

W Taranisie zainstalowałem póki co wersję OpenTX 2.2.1 z 16 grudnia licząc na to, że pojawi mi się opcja wyboru jako "Internal RF Mode" D16-eu jak na waszym zdjęciu ale niestety nie mam takiej opcji (przybyło za to D8). Z tych opcji:

Najczęstsze przyczyny problemów z bindowaniem:

  • Niekompatybilność firmware - wykluczyłem, bo ufam, że właśnie wgrywacie firmware pasujący ze sobą i w Taranisie i w X8R więc póki co tu nic nie zmieniałem
  • Zbyt bliska odległość odbiornika od nadajnika (aparatury RC) - nic to nie zmienia, bo od razu świeci się "solid red & green"
  • Niestabilne lub niewydajne prądowo źródło zasilania - raczej nie ma znaczenia, ale sprawdzałem na 2 źródłach zasilania
  • Zbyt krótkie przytrzymanie przycisku F/S podczas włączania zasilania odbiornika - wykluczone
  • Zły tryb bindowania - ustawiony jest D16 w Internal RF Mode a po naciśnięciu "bind" ustawiam D16+telemetria (kanały 1-8) (w wersji 2.2.1 OpenTX to mi się zaczęło pojawiać)
  • Zły sposób bindowania odbiorników serii V - to odbiornik X, więc odpada

Podsumowując: nie aktualizowałem firmware X8R ani modułu nadawczego Taranisa a jedynie OpenTX do wersji 2.2.1 licząc, że coś to zmieni. Wciąż świeci się po podłączeniu z wciśniętym F/S dioda czerwona i zielona i tak pozostaje. Jeśli nie wcisnę F/S to miga czerwona i tutaj póki co utknąłem.

Edited by almaarde
Link to post
Share on other sites
  • Moderators
5 minut temu, almaarde napisał:

Podsumowując: nie aktualizowałem firmware X8R ani modułu nadawczego Taranisa a jedynie OpenTX do wersji 2.2.1 licząc, że coś to zmieni. Wciąż świeci się po podłączeniu z wciśniętym F/S dioda czerwona i zielona i tak pozostaje. Jeśli nie wcisnę F/S to miga czerwona i tutaj póki co utknąłem.

Zobacz EDIT w moim poprzednim poście.

Najlepiej, gdybyś mógł nagrać krótki filmik (nawet telefonem) pokazujący jak przeprowadzasz bindowanie. Możesz wrzucić go na YT i zamieścić link tutaj, albo w dziale Wsparcia Technicznego (jako nasz Klient niedługo powinieneś dostać mail o włączeniu dostępu do działu Wsparcia).

Sprawdź jeszcze zbyt bliską odległość. Odbiornik zawsze zapali diody, niezależnie od wszystkiego. Ale jeśli jest zbyt blisko radia może się nie bindować, albo mieć niestabilny link po bindowaniu.

Link to post
Share on other sites
  • Moderators

Dzięki za zrobienie filmu.

Robisz wszystko dobrze, może z jedną uwagą, że do drugiego włączenia zasilania odbiornika powinieneś wyjść z trybu bindowania w Taranisie. Nie ma to znaczenia w tym przypadku, bo z tego co widziałem i tak odbiornik się nie zbindował, ale normalnie trzeba by wyjść z trybu bindowania.

Jak pisałem sprawdzamy i bindujemy nadajniki / odbiorniki przed wysyłką (nawet sprzedawane oddzielnie), a wszystkie sprowadzane przez nas produkty mają firmware EU-LBT wgrywany u producenta. Dla pewności można jednak wgrać firmware jeszcze raz. Mamy to dokładnie opisane tutaj:

https://77hobby.pl/uaktualnienie-firmware-urzadzen-smart-port-przez-opentx-21-n-20.html

Jeśli i to nie zadziała, to trzeba będzie odesłać sprzęt do nas w ramach gwarancji.

Zakładam, że w żadnym momencie odbiornik nie został podłączony do nieprawidłowo spolaryzowanego zasilania. W takim przypadku to trochę ruletka: może nie stać się nic, może uszkodzeniu ulec firmware (jego ponowne wgranie pomaga), ale może zostać uszkodzony odbiornik jako taki (zwykle tor zasilania: czasem nie włącza się wcale, czasem objawem jest brak możliwości zbindowania i/lub znaczne ograniczenie zasięgu). Mamy od FrSky procedury serwisowe do sprawdzania i diagnozy takich przypadków, możemy nawet wymienić tor zasilania – ale oczywiście musimy mieć odbiornik u nas).

 

Link to post
Share on other sites

Dzięki za wskazówki. Biorę się zatem za firmware. 

Modelarstwem RC jako takim zajmuje się od 10 lat, trochę już aparatur RC przeszło przez moje ręce, wszędzie procedura bindowania jest podobna więc wykluczam podłączenie odwrotnej polaryzacji do odbiornika. Pin + jest zawsze w środkowym rzędzie więc w sumie ciężko go odwrotnie podpiąć.

Co do firmware mam jeszcze pytanie, na stronie https://www.frsky-rc.com/taranis-x9d-plus-2/ znalazłem Firmware i Firmware -XJT - rozumiem, że chodzi o aktualizację firmware XJT, jako że jest to wewnętrzny moduł nadawczy? Ogólnego FIRMWARE Taranisa nie ruszać?

Link to post
Share on other sites
  • Moderators

Dobrze, że problem rozwiązany :). Aczkolwiek to oznacza, że problemem był prawdopodobnie firmware w module nadawczym, co nie powinno mieć miejsca przy naszych procedurach. Widać jednak, że technologia lub błąd ludzki potrafią sprawić niespodzianki.

Co do odwrotnego podłączenia zasilania, to faktycznie plus zasilania trudno pomylić, jeśli jest w środku standardowego wtyku JR/Hitech. Za to przy podłączaniu dwu-pinowego wtyku JST z baterii już łatwiej źle trafić. Ale nawet przy standardowym wtyku JR zamiana masy z pinem sygnałowym może - i często ma - fatalne skutki. Kompletnie zmienia się poziom GND w całym układzie. W odbiornikach FrSky zwykle uszkodzeniu ulega tor zasilania. Nie zawsze i nie koniecznie kompletnie. Odbiornik się włącza - ale 50/50 już nie działa poprawnie. Jeśli jest uszkodzony to zwykle ma drastycznie ograniczony zasięg, często nie binduje się, albo przestaje działać kilka portów. U innych producentów jest zresztą podobnie. Większe odbiorniki jesteśmy w stanie naprawić, ale już np. R-XSR niekoniecznie...

Link to post
Share on other sites

OK, dzięki za informację. Będę testował czy u mnie wszystko OK z odbiornikiem, ale ewidentnie problemem był firmware XJT wbudowanego, bo już po jego aktualizacji bindowanie ruszyło od razu. Zaktualizowałem później równieź X8R do najnowszej wersji i wszystko wygląda OK. Dzięki za pomoc i w kontakcie :)

Link to post
Share on other sites
  • 3 years later...

Witajcie,
Ja też początkowo miałem problemy z połączeniem X8R z Taranis X9D+ ( 2016 v. LBT). Nadajnik kupiony jako używany z drugiej ręki niedawno                 ( luty 2021) ale pierwszy  właściciel  zakupił go również w 77Hobby w 2016 roku (naklejka, walizka).
     Odbiornik wspomniany kupiłem niedawno też z drugiej ręki od innego modelarza w marcu  ale jeszcze oryginalnie zapakowany. I tak jak w przypadku kolegi "almaarde" to pobranie i aktualizacja  firmware dla wewnętrznego modułu nadajnika XJT i  jak i zewnętrznego odbiornika X8R pomogło. Obydwie wersje firmware jakie wgrałem dla nadajnika i odbiornika to v.2.1.0 ( LBT). 
  Aktualizację  wew. XJT zrobiłem z poziomu nadajnika, a odbiornik przez kabelek wpięty w S-port Taranis- też z poziomu  nadajnika. To taka krótka konkluzja dla reszty poszukiwaczy podobnych informacji.
Pozdrowienia,
 Irek
Kraków

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...